Our Belfair branch lobby is temporarily closed; however, the team is available to serve you using the drive-thru or by scheduling an appointment:

What browser version do I need for digital banking?

The following web browsers are supported by digital banking:

Microsoft Edge or higher
Mozilla Firefox 56 or higher
Google Chrome 62 or higher
Safari 10 or higher

Microsoft Internet Explorer 11 or earlier and Microsoft Windows XP are not supported.

Learn More

Category: Digital Banking